Saturday, January 17, 2009

Slowest RMA processing on the face of the Planet

I've been waiting... and waiting... and waiting.... more or less impatiently for my RMA to process. I must say that this is the slowest service I've ever received from an online vendor. I made the initial purchase on the 17th of December, and received the products on the 23rd. All three components ordered were DOA. I received an RMA and sent them back on the 27th. They were not acknowledged as received until January 8th, and I STILL have not received credit for the items to even reorder new parts. It just goes to show you that going with well established and reputable companies is preferable to dealing with online retailers who may have the lowest price... but not the reputation to go with it.

So I got impatient and ordered a 256 meg stick direct from Crucial and I'm playing with an arch linux install on the old 5 gig hard drive. The realtek wireless usb dongle works fine and I have a basic openbox setup with fbpanel and conky working.

Performance-wise, I really can't complain. It's no barn-burner, but it runs firefox with flash and wicd connects on bootup with no issues whatsoever.

I installed sakura for a terminal emulator and it is both lightweight and very functional. Geany works fine as a text editor, and lxappearance sets the gtk themes.

I'll have more to report once I finally receive the stinking rma and some new parts. Here are some screenshots with wicd and volwheel running.

No comments: